Amiga Unix — 68040 · 68060

Manual pages › System administration commands (1M)

inetd(1M)

Internet services daemon

From the original Amiga UNIX 2.1 manual. Some things it mentions may not be in this release.

NAME

inetd - Internet services daemon

SYNOPSIS

inetd [ -d ] [ -s ] [ configuration-file ]

DESCRIPTION

inetd, the Internet services daemon, is normally run at boot time by the Service Access Facility (SAF). When started, inetd reads its configuration information from configuration-file, the default being /etc/inetd.conf. See inetd.conf(4) for more information on the format of this file. It listens for connections on the Internet addresses of the services that its configuration file specifies. When a connection is found, it invokes the server daemon specified by that configuration file for the service requested. Once a server process exits, inetd continues to listen on the socket.

The -s option allows you to run inetd ``stand-alone,'' outside the Service Access Facility (SAF).

Rather than having several daemon processes with sparsely distributed requests each running concurrently, inetd reduces the load on the system by invoking Internet servers only as they are needed.

inetd itself provides a number of simple TCP-based services. These include echo, discard, chargen (character generator), daytime (human readable time), and time (machine readable time, in the form of the number of seconds since midnight, January 1, 1900). For details of these services, consult the appropriate RFC, as listed below, from the Network Information Center.

inetd rereads its configuration file whenever it receives a hangup signal, SIGHUP. New services can be activated, and existing services deleted or modified in between whenever the file is reread.

SEE ALSO

comsat(1M),  ftpd(1M),  rexecd(1M),  rlogind(1M),  rshd(1M),
telnetd(1M), tftpd(1M), inetd.conf(4).

Postel, Jon, ``Echo Protocol,'' RFC 862, Network Information
Center, SRI International, Menlo Park, Calif., May 1983.

Postel, Jon, ``Discard Protocol,'' RFC 863, Network Informa-
tion  Center,  SRI  International,  Menlo  Park, Calif., May
1983.

Postel, Jon, ``Character Generater Protocol,'' RFC 864, Net-
work  Information  Center,  SRI  International,  Menlo Park,
Calif., May 1983.

Postel, Jon, ``Daytime Protocol,'' RFC 867, Network Informa-
tion  Center,  SRI  International,  Menlo  Park, Calif., May
1983.

Postel, Jon, and Ken  Harrenstien,  ``Time  Protocol,''  RFC
868,  Network  Information  Center, SRI International, Menlo
Park, Calif., May 1983.